前几天给大家分享了:Cobalt Strike安装使用教程与DNS通讯演示[转]。可能很多朋友在使用过程中遇到了很多问题,这里就不一一解释了,大家有什么问题可以评论区留言给我。

今天给大家带来的是kali2.0下cobaltstrike的安装方法,之所以kali2.0要单独说,是因为默认情况下使用cobalt strike会报错:“msgpack.UnpackException: parse error at server.sl:453”

kali2.0无法使用cobaltstrike报错

 

在网上找了一番,貌似没有国人反应这个问题,在github上看到不少人在讨论这个,但都是英文(原帖:https://github.com/rsmudge/armitage/issues/184),这个问题后续kali可能会发布补丁,但是现在还是有解决方案的。

解决方法

使用armitage,基本上和cobaltstrike是一样的。

下载地址: http://www.fastandeasyhacking.com/download

直接解压打开

tar -xf armitage150813.tgz
cd armitage
./armitage

但会提示你数据库配置不正确,需要初始化一下

kali2.0无法使用cobaltstrike报错

命令:

msfdb init

如果下次重启可能还会提示postgres数据库没有启动:

kali2.0无法使用cobaltstrike报错

就需要使用如下命令来启动

msfdb start

另外,非正常关闭可能还需要你使用kill命令来结束掉msfrpcd服务等等,这都是常见操作。

至此kali2.0正常使用

kali2.0无法使用cobaltstrike报错

您的支持将鼓励我们继续创作!

[微信] 扫描二维码打赏

[支付宝] 扫描二维码打赏